← Back to CVE List
CVE-2024-45409NVD
Vulnerability Summary
The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.
CVSS v3.1 Base Metrics — Score 10.0 (CRITICAL)
Attack VectorNetwork
Attack ComplexityLow
Privileges RequiredNone
User InteractionNone
ScopeChanged
ConfidentialityHigh
IntegrityHigh
AvailabilityNone
Affected & Patched Versions
- Onelogin Ruby-saml < 1.12.3
- Onelogin Ruby-saml >= 1.13.0 and < 1.17.0
- Omniauth Omniauth Saml <= 1.10.3
- Omniauth Omniauth Saml
- Gitlab Gitlab < 16.11.10
- Gitlab Gitlab >= 17.0.0 and < 17.0.8
- Gitlab Gitlab >= 17.1.0 and < 17.1.8
- Gitlab Gitlab >= 17.2.0 and < 17.2.7
- Gitlab Gitlab >= 17.3.0 and < 17.3.3
- Onelogin Ruby-saml 1.12.3
- Onelogin Ruby-saml 1.17.0
- Gitlab Gitlab 16.11.10
- Gitlab Gitlab 17.0.8
- Gitlab Gitlab 17.1.8
- Gitlab Gitlab 17.2.7
- Gitlab Gitlab 17.3.3
External References
- https://github.com/SAML-Toolkits/ruby-saml/commit/1ec5392bc506fe43a02dbb66b68741051c5ffeae
- https://github.com/SAML-Toolkits/ruby-saml/commit/4865d030cae9705ee5cdb12415c654c634093ae7
- https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2
- https://github.com/omniauth/omniauth-saml/security/advisories/GHSA-cvp8-5r8g-fhvq
- https://lists.debian.org/debian-lts-announce/2024/11/msg00006.html
- https://news.ycombinator.com/item?id=41586031
- https://security.netapp.com/advisory/ntap-20240926-0008/
- https://ssoready.com/blog/engineering/ruby-saml-pwned-by-xml-signature-wrapping-attacks/