← Back to CVE List
CVE-2026-39892NVD
Vulnerability Summary
cryptography is a package designed to expose cryptographic primitives and recipes to Python developers. From 45.0.0 to before 46.0.7, if a non-contiguous buffer was passed to APIs which accepted Python buffers (e.g. Hash.update()), this could lead to buffer overflows. This vulnerability is fixed in 46.0.7.
CVSS v4.0 Base Metrics — Score 6.9 (MEDIUM)
Attack VectorNetwork
Attack ComplexityLow
Attack RequirementsNone
Privileges RequiredNone
User InteractionNone
Confidentiality (Vulnerable System)None
Integrity (Vulnerable System)None
Availability (Vulnerable System)Low
Confidentiality (Subsequent System)None
Integrity (Subsequent System)None
Availability (Subsequent System)None
Affected & Patched Versions
- pyca cryptography >= >= 45.0.0, < 46.0.7
Not provided by cveorg for this CVE.
External References
- https://github.com/pyca/cryptography/security/advisories/GHSA-p423-j2cm-9vmq
- https://github.com/pyca/cryptography/commit/622d672e429a7cff836a23c5903683dbec1901f5
- https://github.com/pyca/cryptography/commit/c09d38ae52de7d95fe683b7a7c496f5751616f27
- https://github.com/pypa/advisory-database/tree/main/vulns/cryptography/PYSEC-2026-36.yaml