Everest Forms patches a critical 9.8 CVSS PHP Object Injection vulnerability affecting 100,000+ sites. Update to v3.4.4 now to prevent full site takeover!
Everest Forms
A critical PHP object injection flaw (CVE-2025-52709, CVSS 9.8) in Everest Forms allows RCE when an admin views form submissions on PHP versions below 7.1. Update to v3.2.3 immediately.
A critical vulnerability in the Everest Forms WordPress plugin allows unauthenticated attackers to inject PHP Objects. Update to version 3.1.2 immediately to protect your site.
Urgent: CVE-2025-1128 affects Everest Forms. Find out how to prevent site compromise by updating to the latest version.