Upgrade to Apache bRPC 1.18.0 to patch 35 Apache bRPC vulnerabilities, including high-severity flaws CVE-2026-48830 and CVE-2026-56388.
Apache bRPC
Apache patches bRPC flaw CVE-2025-60021. Vulnerable heap profiler allows remote command injection. Upgrade to v1.15.0 to secure your infrastructure.
A critical vulnerability in Apache bRPC (CVE-2025-59789) allows attackers to crash servers using deep JSON data. Upgrade to version 1.15.0 now to fix it.
A critical flaw in Apache bRPC's Redis parser (CVE-2025-54472) allows unauthenticated remote attackers to crash services via a memory allocation bug. Update to 1.14.1 immediately!
CVE-2024-23452 flaw that could potentially allow attackers to smuggle malicious requests through the bRPC's HTTP server.
The vulnerability, CVE-2023-45757, is an XSS vulnerability. XSS vulnerabilities allow attackers to inject malicious code into web pages
The flaw in question, CVE-2023-31039, has been classified as "important" in terms of severity and affects Apache bRPC versions 0.9.0 through 1.4.9